Dedizierter server Ark Server .. Mod installieren nicht möglich?

  • Hallo ARK Freunde,


    weil dieses Thema ---> Ark Mods hinzufügen nicht möglich. (core dumped)

    schon ein bisschen her ist mal neu aufmachen

    und weitere Suche hier im Forum hat nichts weiteres relevantes ergeben


    ist inzwischen eine Lösung für dieses Problem gefunden?

    ich habe auch das Problem das die Mods nicht geladen werden


    ich sehe aber das Imba Limba 420 in seinem Startbefehl -automanagedmods drin hat .. der is mir neu ?(

    was macht der Befehl und wie funzt er ...

    wenn ich den bei mir einfüge stürzt der Server ab

    Code
    1. ./ShooterGameServer Crystalisles?MaxPlayers=10?AutoSavePeriodMinutes=15.000000?RCONEnabled=true?RCONPort=XXXXX?QueryPort=XXXXX?ServerAdminPassword=XXXXXXX?Port=XXXXX?listen? -server -log -NoBattlEye -automanagedmods -exclusivejoin
    2. und mit AktiveMods=.... in GUS.ini

    hab ich irgendwas wieder verpasst das man in Ark die Mods MAL WIEDER anders laden muß?

    man findet iwi auch keine Anmerkungen dazu im Netz was ab Pach 312 gemacht werden muß

    oder ich bin blind bei der Suche

    hatte das letzte mal Oktober 2018 einen Server, da ging es noch mit AktiveMods=... in der GUS.ini und zusätzlich Modsloader & ModIDS=... in der Game.ini ... ohne irgendeinen anderen Befehl oder Zusatz

    währ schön wenn mir jemand helfen könnte

    und nein ich verwende keinen Ark Server Manager

    weil ich die Installation nicht verstehe

    da ja immer bei Tutorials GRUNDKENNTNISSE vorausgesetzt werden :rolleyes:

    aber wie man die bekommt is ne Andere Sache .. vorallem wenn für einem Englisch seine schwer verstehbare Sprache ist .. war auch in der Schule schon so


    mfG ORKA



    P.S. hoffe bin hier im richtigen Bereich dafür

    *wer Schreibfehler findet darf sie behalten* modo

  • AktiveMods=

    Hi,


    hast du den Befehl genauso in der gus.ini geschrieben?

    Dann ist er falsch, denn es muss "ActiveMods=" heißen.

    Auch muss der Befehl in die Sektion "[ServerSettings]".

    Ich habe zwar keine Lösung, aber bewundere das Problem!


    Wenn DAS ihre Lösung ist, hätte ich gerne mein Problem zurück!

  • Hey,


    automanagemods ist ein Startparameter, der alle Mods, die du in der GUS festgelegt hast, installiert, ladet und /oder updatet immer wenn du den Server gestartet hast.


    Etwas, das du immer machen kannst, ist den log anzusehen. Logs auslesen ist immer sehr wichtig, um Probleme zu finden :). Start mal den Server, wart bis er up is oder gecrasht und schau dann in die Logfile. Am besten hängst sie hier an, damit man mal drüberlesen kann.


    Normalerweise werden Mods nur dann nicht geladen, wenn die korrupt sind oder einfach nicht installiert hast.

    Der Crash kann viele ursachen haben, meistens sind das Probleme bei den Schreibrechten, dass der Server keine Rechte hat, diese Mods zu installieren... Kann aber auch wenig speicherplatz sein oder mehr.


    Ist deine ARK Instanz auf dem neuesten Stand ? :)

  • Normalerweise werden Mods nur dann nicht geladen, wenn die korrupt sind oder einfach nicht installiert hast.

    öööhm .. das soll automatisch gehen
    also vor nicht mal ganz 2 Jahren ging das noch in Game.ini und ModIDS=...

    jetzt nicht mehr
    ich möchte NICHT immer die aktuellen Mods hochladen müssen


    [edit]


    Zitat

    Der Crash kann viele ursachen haben, meistens sind das Probleme bei den Schreibrechten, dass der Server keine Rechte hat

    da hatte ich früher kein Problem mit den rechten



    also das zeigt mir die Konsole (putty) an wenn ich versuche mit automanagedmods und in der GUS.ini ActiveMods=... zu starten ... absturz


    ein log hab ich iwi keines das die fehler zeigt . oder ich bin zu doof das zu finden X/


    oder ist in meiner Start.sh was falsch bzw fehlt was?

    Code
    1. cd /home/XXXXX/steamcmd
    2. ./steamcmd.sh +login anonymous +force_install_dir /home/XXXXX/ARK +app_update 376030 +quit
    3. cd /home/XXXXX/ARK/ShooterGame/Binaries/Linux
    4. ulimit -n 100000
    5. ./ShooterGameServer Crystalisles?MaxPlayers=10?AutoSavePeriodMinutes=15.000000?RCONEnabled=true?RCONPort=XXXXX?QueryPort=XXXXX?ServerAdminPassword=XXX?Port=XXXXX?listen? -server -log -NoBattlEye -exclusivejoin -automanagedmods


    ich hab mal testweise einen Server aufgesetzt mit dieser Anleitung


    bekomm ich überhaupt nicht zum laufen

    evtl veraltet


    bitte Hilfe

    wir brauchen Mods ||


    [nochmal edit]


    das hab ich erst jetzt richtig gelesen :rolleyes:


    Zitat

    Start mal den Server, wart bis er up is oder gecrasht und schau dann in die Logfile.


    der Server kommt ja nicht mal zum laufen er stürzt ja gleich beim Starten ab .. da kann ich ja kein Log finden dash

    *wer Schreibfehler findet darf sie behalten* modo

    2 Mal editiert, zuletzt von ORKAdlg ()

  • Klar funktioniert das nicht, schau mal deinen Screenshot an und lies die Zeilen durch. Die Steam API fehlt oder läuft nicht bei dir. Wo ist denn die drin, hast du die steam api installiert ?


    Wie ich sehe ist das ein Linux Server. Ich habe selbst auch einen Cluster am laufen, aber mit Arkmanager weil das viel einfacher zu maintainen ist.

  • Die Steam API fehlt oder läuft nicht bei dir. Wo ist denn die drin, hast du die steam api installiert ?

    ähm wo und wie gehört das rein????

    und sry für die dumme frage ... steam api?


    ich sag ja früher hat es GENAU so funktioniert .. ohne -automanagedmods

    und man findet nichts offizielles .. zumindest ich ... was man angeben muß um den Server mit Mods zu starten .. wenn es ab einem Pach geändert wurde


    und den Ark manager bekomme ich nicht zum laufen hab gestern versucht einen test Server aufzubauen

    s.o.


    Soubi hast Du gute Kenntnisse für Server? soviel um richtig helfen zu können?


    ich habe nur rutimentäres Wissen in Linux und das ein bisschen erweitert
    da ich mit dem englischen nicht so gut klar komme und es anstrengend ist mich da rein zu lesen ... wenn ich mal was verstanden habe muß ich es mir aufschreiben ... sonst weis ich es nach einiger Zeit nicht mehr wenn es nicht benutzt wird

    und nun fragt man sich sicher "Warum zu Teufel benutzt er dann einen Linux Server, wenn es doch schon fertige GameServer gibt?"


    na eben weil man den eigenen besser und frei von Vorgaben einstellen kann .. und weil es ein ECHTER Server ist und kein virtueller <-- bitte wenn dann dazu nur ernste Fragen und keine besserwissenden Kommentare .. hatte erst gestern einen der nur auf seine gestellte Frage... wo mein Server steht ... und ich nicht geantwortet habe .. kindisch reagiert und mich danach geblockt

    nur weil man nicht so bewandert im Programmieren ist, sollte dies in der heutigen Zeit aber kein Hinderniss sein, demjenigen es zu ermöglichen einen LinuxServer zu leiten und es detailiert erklärt auch beizubringen/zeigen

    *wer Schreibfehler findet darf sie behalten* modo

    Einmal editiert, zuletzt von ORKAdlg ()

  • Die Lösung hierbei war sehr spezifisch auf seiner Linux Distribution und handelte sich um die Rechtevergabe der einzelnen User und auszuführenden Dateien.
    Wenn man sich mit Unix Systemen auskennt (Grundkenntnisse vorrausgesetzt), hat man dieses spezifische Problem einfach nicht. Egal ob per Arkmanager oder ohne.

    Weiters haben wir Arkmanager installiert, da mit diesem die Administration einfach viel leichter ist.


    Daher solltet Ihr, wenn Ihr ebenfalls Probleme habt, immer genau euer Problem hier posten (am Besten mit Logfiles) damit man sich das ansehen kann und nicht von anderen Problemen nachlesen und dann irgendetwas selbst zusammenschustern, denn es gibt verschiedene Linux Betriebssysteme und die Server sidn je nach Person sowieso anders aufgebaut (auch was alleine schon die Firewall betrifft).