Cluster ID

  • PC

Ankündigung! PC v257 Update, Veränderungen des Vulkans & erste Musik-Teaser!
Aktuelle Patchnotes
ARK PS4 Patchnotes 506.0 | Veröffentlicht NEU
ARK PS4 Patchnotes 506.3 | Veröffentlicht NEU
ARK Patchnotes 257.0 | Angekündigt
ARK Patchnotes 256.61 | Veröffentlicht NEU
ARK Patchnotes 256.7 | Veröffentlicht NEU
ARK XBOX Patchnotes 753.0 | Veröffentlicht NEU
ARK Xbox Patchnotes 753.1 | Veröffentlicht NEU

  • Alle Cross Server müssten auf das Selber Verzeichnis verlinkt sein , zB. arkopt_ClusterDirOverride=/home/x/clusters (alle instanz.cfg prüfen).
    Alle Cross Server müssen idenzische ID haben (hab hier alles kleingeschrieben + Zahlen).
    Alle Cross Server müssen kleiche cross Einstellung haben

    Dies steht bei allen meinen instanzen.cfg:

    Quellcode

    1. # ark cluster settings
    2. arkflag_NoTransferFromFiltering=false
    3. arkopt_clusterid=meinelieblingsid1234
    4. #ark_PreventDownloadSurvivors=False
    5. #ark_PreventDownloadItems=False
    6. #ark_PreventDownloadDinos=False
    7. #ark_PreventUploadSurvivors=False
    8. #ark_PreventUploadItems=False
    9. #ark_PreventUploadDinos=False
    10. #ark_noTributeDownloads=false
    11. arkopt_ClusterDirOverride=/home/xxx/xxx/ShooterGame/Saved/clusters
    Alles anzeigen
    mehr ist nicht nötig damit es funktioniert.
    (Bis auf einsprechende Rechte für user)

    EDIT:

    Und bitte denk daran, Einstellungen sind erst Wirksam nach einem restart :)

    beste Grüße
    mctiger
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)

  • Hey,
    hast du Dir das schonmal angeschaut? Das hat mir oft geholfen bei Problemen

    ARK Hilfe und Tutorials PDF


    Grüße,
    dein ARKGott
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)
  • 00julius schrieb:



    arkmanager.cfg:
    configfile_The_Center="/etc/arkmanager/instances/The_Center.cfg"

    configfile_The_Island="/etc/arkmanager/instances/The_Island.cfg"
    #defaultinstance="main"



    Konfiguration Center:

    arkopt_clusterid=aaaaa

    arkopt_ClusterDirOverride=/home/x/Daten/steamserver/arkdedicated/ShooterGame/Saved/SavedArks


    Konfiguration Island:
    arkopt_clusterid=aaaa

    arkopt_ClusterDirOverride=/home/x/Daten/steamserver/arkdedicated/ShooterGame/Saved/SavedArks

    Die Defaultinstanz würde ich drin lassen, da er sonst bei arkmanager update (ohne @map) eventuell mal den falschen erwischt. Ich hab default auf @test gesetzt, das ist unser Testserver.

    Ich hoffe das aaaaa(5) und aaaa(4) wurde nicht so übernommen? Das würde zumindest erklären, wenn die Server nicht im selben Cluster sind ;)

    X0lfm4n schrieb:

    scheinbar gibt es doch noch probleme mit dem transfer der charactere die gehen leider verloren :(
    Gehen denn Dinos oder Items?
  • Schau mal ob das vielleicht hilft: Klick mich - hat mir geholfen

    LG
    Cody
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)
  • Hmm, dann scheint das grundsätzlich richtig eingestellt zu sein, denn in Wirklichkeit ist der "cluster" einfach nur ein Verzeichnis, in dem Dateien liegen. Deren Dateiname ist jeweils die SteamID des Spielers, der die Sachen hochläd.

    Das einzige, was ich mir vorstellen könnte, ist, dass eventuell der Characterupload verboten ist. Daher: Geht der upload erst gar nicht oder läd er den Char hoch und danach ist er weg? Wenn das zweite der Fall ist, schau doch mal, was er in das Cluster-Verzeichnis rein schreibt, nach dem du a) Dinos b) Char c) Dinos+Char hochlädst.
  • Als Test würde ich nicht einen Map Ordner verwenden, da dort auch die normalen Character Daten liegen - das könnte zu Problemen kommen.

    Ein Beispiel Pfad:
    arkopt_ClusterDirOverride=/home/x/Daten/steamserver/arkdedicated/Cluster

    Den Ordner zur Sicherheit vorher per FTP / ssh anlegen.

    Ich denke damit könnte das Problem gelöst werden.
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)
  • Schau mal ob das vielleicht hilft: Klick mich - hat mir geholfen

    LG
    Cody
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)
  • Neu

    Sieht eigentlich ok aus .

    Versuch mal damit in beiden instanz.cfg.

    Spoiler anzeigen
    # ark cluster settings
    arkflag_NoTransferFromFiltering=false
    arkopt_clusterid=meineclusterid123456789
    #ark_PreventDownloadSurvivors=False
    #ark_PreventDownloadItems=False
    #ark_PreventDownloadDinos=False
    #ark_PreventUploadSurvivors=False
    #ark_PreventUploadItems=False
    #ark_PreventUploadDinos=False
    #ark_noTributeDownloads=false
    arkopt_ClusterDirOverride=/home/ark/server/cluster


    So funktioniert bei mir alles ohne Probleme.

    Ich würde vielleicht in arkmanager.cfg vom main Server alles ausklammern und alles mit den instanzen steuern (ist alles doppelt sonst).
    So mache ich das und läuft problemlos.

    Spoiler anzeigen
    # ARK server common options - use ark_<optionname>=<value>
    # comment out these values if you want to define them
    # inside your GameUserSettings.ini file
    #serverMap="TheIsland" # server map (default TheIsland)
    #serverMapModId="469987622" # Uncomment this to specify the Map Mod Id (<fileid> in ?id=<fileid>)
    #ark_TotalConversionMod="496735411" # Uncomment this to specify a total-conversion mod
    #ark_RCONEnabled="True" # Enable RCON Protocol
    #ark_ServerPassword="" # ARK server password, empty: no password required to login
    #ark_ServerAdminPassword="" # ARK server admin password, KEEP IT SAFE!
    #ark_MaxPlayers="50"
    #ark_GameModIds="731604991" # Uncomment to specify additional mods by Mod Id separated by commas
    #ark_AltSaveDirectoryName="SotF" # Uncomment to specify a different save directory name

    # ARK server flags - use arkflag_<optionname>=true
    #arkflag_OnlyAdminRejoinAsSpectator=true # Uncomment to only allow admins to rejoin as spectator
    #arkflag_DisableDeathSpectator=true # Uncomment to disable players from becoming spectators when they die

    # ARK server options - i.e. for -optname=val, use arkopt_optname=val
    #arkopt_StructureDestructionTag=DestroySwampSnowStructures

    # config Service
    logdir="/var/log/arktools" # Logs path (default /var/log/arktools)

    # steamdb specific
    appid=376030 # Linux server App ID
    mod_appid=346110 # App ID for mods

    # Mod OS Selection
    mod_branch=Windows
    # Add mod-specific OS selection below:
    #mod_branch_496735411=Windows

    # alternate configs
    # example for config name "ark1":
    #configfile_main="/home/ark/cfg/pve.cfg"

    #defaultinstance="main"


    EDIT:
    du hast auch viele Prevent Einstellungen in deiner gus.ini, ich würde vielleicht die gus.ini auch mal sauber machen und die benötigten Einstellungen wieder vornehmen.

    beste Grüße
    mctiger
  • Schau mal ob das vielleicht hilft: Klick mich - hat mir geholfen

    LG
    Cody
  • Hinweis: Supporter sehen keine Werbung. Hier klicken um Supporter zu werden (Benötigt eine kostenlose Mitgliedschaft im Forum)
  • Hab ihr das mal angeschaut, ob das vielleicht helfen könnte? ARK Cheats

    LG
    der Kartoffelkopp